Author Topic: "Müll" im Upload-Stream?  (Read 7185 times)

0 Members and 1 Guest are viewing this topic.

Offline Doc Honke

  • Elite
  • *****
  • Posts: 1374
  • Karma: +21/-8
    • View Profile
"Müll" im Upload-Stream?
« on: January 04, 2010, 07:29:39 AM »
0.8.7.4 beta
1 aktive .avi-Suche

Gesamt-Download (GD): 40 KiB/s
Gesamt-Upload (GU): 180 KiB/s
Effektiver Download (ED): 0 KiB/s
Effektiver Upload (EU): 80 KiB/s

GU - GD - EU = 120 KiB/s

Wo gehen die 60 KiB/s Upload hin, bzw. welchen Inhalt haben die?  ???

Offline DiGiT@LoN€ ITA

  • Elite
  • *****
  • Posts: 372
  • Karma: +4/-4
  • "SOS brigade" member
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #1 on: January 04, 2010, 10:34:43 AM »
Wo gehen die 60 KiB/s Upload hin, bzw. welchen Inhalt haben die?  ???
Search queries? ;D

Offline Doc Honke

  • Elite
  • *****
  • Posts: 1374
  • Karma: +21/-8
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #2 on: January 04, 2010, 10:38:40 AM »
Only 1 active .avi search .... that cannot be the reason.

Offline Nemo

  • Global Moderator
  • Elite
  • *****
  • Posts: 1303
  • Karma: +27/-0
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #3 on: January 04, 2010, 11:01:25 AM »
Wo gehen die 60 KiB/s Upload hin, bzw. welchen Inhalt haben die?  ???
Es müssten Netzwerkkommandos sein, die bei dir mehr Upload- als Downloaddatenmenge erzeugen:
-Suchresultate von deinem Knoten, als Antwort auf Suchanfragen anderer Nutzer.
-Broadcastweiterleitung von Suchanfragen und Quellenanfragen anderer Knoten (kommen auf einer P2P-Verbindung rein, gehen auf allen anderen P2P-Verbindungen raus).

MfG,
Nemo.

Offline Doc Honke

  • Elite
  • *****
  • Posts: 1374
  • Karma: +21/-8
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #4 on: January 04, 2010, 11:06:34 AM »
Das wäre aber ein Wahnsinns-Overhead, oder nicht? Geht manchmal bis auf 80 KiB/s hoch.

Offline Äffchen

  • Mitquatscher
  • Elite
  • *****
  • Posts: 1390
  • Karma: +14/-7
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #5 on: January 04, 2010, 11:26:14 AM »
vielleicht musst du ja soviel infos bei suchanfragen rausschicken...

Offline DiGiT@LoN€ ITA

  • Elite
  • *****
  • Posts: 372
  • Karma: +4/-4
  • "SOS brigade" member
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #6 on: January 04, 2010, 12:17:37 PM »
Das wäre aber ein Wahnsinns-Overhead, oder nicht? Geht manchmal bis auf 80 KiB/s hoch.
mmm, if the search was ".avi" in "only network" mode I don't think so. Generally, it depends...

Nemo have explained the possible reason, and we know that ".avi" search gets a lot of results from many clients (considering also you had 10 direct connections).
Probably the clients which sent you the search results was a great number, and your client had to send them other commands like Nemo's explained.
60 KB are very much, but it depends on the number of clients which you're responding...
So, you're right only if that number was little...otherwise I think it's normal.

These are my 2 cents... ;D

Offline internationalannoyance

  • Advanced
  • ***
  • Posts: 208
  • Karma: +19/-79
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #7 on: January 04, 2010, 01:33:29 PM »
ich kann das phaenomen aktuell heute im moment bestaetigen. ich habe 1kbyte sec upload aus echten dateien, auch mit filemon beobachtet, stealthnet.exe macht kaum noch dateizugriffe, aber processexplorer (sysinternals) zeigt z.b. ueber 40threads innerhalb des stealthnet.exe  processes an die alle mal wieder (wie frueher auch schon oefters mal in den foren als fehlerreport von diversen usern aufgetaucht) viele threads mit immer den gleichen einsprungspunkten, die alle 1-2 aber oft auch 4-8% cpu last fahren. alle halbe minute oder minute sterben die threads ab und werden durch neue (neue IDs) ersetzt und das spiel geht von vorne los.

also entweder ist schon wieder ein (d)dos attack auf stealthnet moeglich, oder es haben sich zu viele feherhafte (beta clients?) nodes gruppiert oder sonstwas laeuft schief.

download hatte ich ca. 60kbytes, outgoing 180kbytes total, aber eigene daten upload wie gesagt nur 1kbytes total, und der rest der requested files war bereits aktiv im upload aber alle bei zero bytes/sec.

riecht nach bug oder exploitability.
mfg.

Offline Doc Honke

  • Elite
  • *****
  • Posts: 1374
  • Karma: +21/-8
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #8 on: January 04, 2010, 01:42:51 PM »
Das mit der hohen Prozessorauslastung kann ich bestätigen. Fast wie früher, nur dass diesmal SN noch reagiert und man ihn ordnungsgemäoß schließen kann.

EDIT: WinXP SP3, alle Fixes, 0.8.7.4 beta
« Last Edit: January 04, 2010, 01:48:45 PM by Doc Honke »

Offline blewzahr

  • Advanced
  • ***
  • Posts: 278
  • Karma: +21/-22
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #9 on: January 04, 2010, 01:47:04 PM »
same here: ich hab gerade den client restarted, und jetzt hab ich innerhalb von 5mins seit cycle bereits 50down und 160up (kbytes) aber keine eigenen files am uppen und nada am downen.

was geht hier schon wieder ab?

winxp, sp3, latest fixes, 0.8.7.4beta

p.s. bei der connection uebersicht, meist keine enqueued commands, aber teilweise sehr viele (10er setting) davon auf 25stueck enqueued, dann runter auf einstellig, dann wieder null, und dann wieder rauf. flood? wir brauchen mehr stats zu techn. interna wie verworfene pakete, falsche, corrupte, defekte pakete, usw etc. so ist kein sinnvolleres debugging moeglich.
« Last Edit: January 04, 2010, 01:50:02 PM by blewzahr »

Offline internationalannoyance

  • Advanced
  • ***
  • Posts: 208
  • Karma: +19/-79
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #10 on: January 04, 2010, 01:57:02 PM »
ich hab hier auch im schnitt keine kommandos auf der queue, aber wenn was ist, dann "faengts" immer bei folgendem derzeit verbundenem host an (franzosen ip, provider scheint auch business lastig zu sein, fibre conn aber auch symm dsl, usw)

194.79.181.238:62228

ip loest nach keinem namen auf, aber ripe nennt die details.

evtl ist das nen telco attack oder nen amok client oder jemand testet und fummelt am sourcecode und hat nen xploit am fahren?


muss aber nicht unbedingt mit diesem host zu tun haben, ich hab n paar andere stealthnet nodes die scheinen nur consumer nodes am anderen ende zu haben und da summieren sich auch alle paar sekunden fast alle connections auf 25queue hoch, danach wieder alles sauber, und dann erneut.

p.s. hatte eben beim restarten des clients mit diesem phaenomen auch gleich wieder mal nen exit crash, bei dem er bemeckerte dass er wieder mal configfiles nicht speichern koenne, aber nach restart des clients sieht alles normal aus (config technisch), und ich hab auch keine zero-bytes files im preferences directory.)

screen: http://bayimg.com/LAJgOAacG
« Last Edit: January 04, 2010, 02:03:58 PM by internationalannoyance »

Offline DiGiT@LoN€ ITA

  • Elite
  • *****
  • Posts: 372
  • Karma: +4/-4
  • "SOS brigade" member
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #11 on: January 04, 2010, 03:16:35 PM »
also entweder ist schon wieder ein (d)dos attack auf stealthnet moeglich,
RShare net is still too young for this...I think.
At this moment, which is the reason for making a DoS attack to SN?

Offline internationalannoyance

  • Advanced
  • ***
  • Posts: 208
  • Karma: +19/-79
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #12 on: January 04, 2010, 03:28:13 PM »
we already had exploit "abuse" from some of the sourcecode analysts here in the forums, who were showing the developers that there were some bugs in the core of stealthnet that they were able to exploit. search the forums.

besides, it was only a guess. something musthavehappend as the network seems to generate and relay crappy data these days only. hardly any useful data enter and leave my nodes at least. and thats what others are experiencing too, as we are having this thread right here.

wonder why you cant see the problem

Offline Doc Honke

  • Elite
  • *****
  • Posts: 1374
  • Karma: +21/-8
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #13 on: January 04, 2010, 03:38:19 PM »
Komisch: Wenn SN bei den Downloads (und vielleicht Uploads) genug zu tun hat, dann entsteht kein Overhead ..... oder Zufall? - Keine aktiven Suchen; 6000 freigegebene Dateien

Offline DiGiT@LoN€ ITA

  • Elite
  • *****
  • Posts: 372
  • Karma: +4/-4
  • "SOS brigade" member
    • View Profile
Re: "Müll" im Upload-Stream?
« Reply #14 on: January 04, 2010, 08:01:37 PM »
we already had exploit "abuse" from some of the sourcecode analysts here in the forums, who were showing the developers that there were some bugs in the core of stealthnet that they were able to exploit. search the forums.
I know.
But these attacks were made by internal analyst, who said they did that.
I was talking about the fact that it's difficult that someone who is external attacks the Rshare network.
Do you think that someone of analyst is trying to abuse or attack the network? Maybe it would be possible...
But someone who is against P2P, maybe think to attack Torrent, and not RShare...there's a low probability.

These are my   ;D
besides, it was only a guess. something musthavehappend as the network seems to generate and relay crappy data these days only. hardly any useful data enter and leave my nodes at least. and thats what others are experiencing too, as we are having this thread right here.

wonder why you cant see the problem
No, I see the problem now and don't exclude it exists. But I usually connect directly with a friend of mine and he's downloaded some files correctly. Luckily there's no problem of corrupted data...
However, I think that more probably it's a problem of routing.
Maybe because a lot of users are using the beta.