Author Topic: openssl-0.9.7g-xpgp-0.1c g++ error  (Read 2541 times)

0 Members and 1 Guest are viewing this topic.

Offline Col Parnick

  • Posts: 2
  • Karma: +0/-0
    • View Profile
openssl-0.9.7g-xpgp-0.1c g++ error
« on: March 21, 2009, 07:25:36 PM »
Hallo, ich compiliere gerade RS unter linux. 2.6.21.7

Code: [Select]
$ cd ~/src
$ wget http://www.lunamutt.com/retroshare/openssl-0.9.7g-xpgp-0.1c.tgz
$ tar -xzvf openssl-0.9.7g-xpgp-0.1c.tgz
$ cd openssl-0.9.7g-xpgp-0.1c
$ ./config --openssldir=/etc/ssl-xpgp no-shared
$ make
[...]
In file included from x_xPGP.c:69:
../../include/openssl/xPGP.h:382:30: error: openssl/xPGP_vfy.h: No such file or directory

Der Pfad stimmt, aber das File fehlt tatsächlich ?!

Code: [Select]
In file included from x_xPGP.c:69:
../../include/openssl/xPGP.h:479: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
make[2]: *** [x_xPGP.o] Error 1
make[2]: Leaving directory `/root/src/openssl-0.9.7g-xpgp-0.1c/crypto/asn1'
make[1]: *** [subdirs] Error 1
make[1]: Leaving directory `/root/src/openssl-0.9.7g-xpgp-0.1c/crypto'
make: *** [sub_all] Error 1

Rückfragen? Ideen?

Offline crypton

  • Elite
  • *****
  • Posts: 1699
  • Karma: +10/-0
    • View Profile
Re: openssl-0.9.7g-xpgp-0.1c g++ error
« Reply #1 on: March 21, 2009, 09:23:11 PM »
Hallo, ich compiliere gerade RS unter linux. 2.6.21.7

Code: [Select]
$ cd ~/src
$ wget http://www.lunamutt.com/retroshare/openssl-0.9.7g-xpgp-0.1c.tgz
$ tar -xzvf openssl-0.9.7g-xpgp-0.1c.tgz
$ cd openssl-0.9.7g-xpgp-0.1c
$ ./config --openssldir=/etc/ssl-xpgp no-shared
$ make
[...]
In file included from x_xPGP.c:69:
../../include/openssl/xPGP.h:382:30: error: openssl/xPGP_vfy.h: No such file or directory

Der Pfad stimmt, aber das File fehlt tatsächlich ?!

Code: [Select]
In file included from x_xPGP.c:69:
../../include/openssl/xPGP.h:479: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
make[2]: *** [x_xPGP.o] Error 1
make[2]: Leaving directory `/root/src/openssl-0.9.7g-xpgp-0.1c/crypto/asn1'
make[1]: *** [subdirs] Error 1
make[1]: Leaving directory `/root/src/openssl-0.9.7g-xpgp-0.1c/crypto'
make: *** [sub_all] Error 1

Rückfragen? Ideen?


hast du openssl installiert auf deinem linux?
es gibt probleme wenn du openssl auf linux schon installiert ist und du RetroShare's openssl kompilieren willst.
poste mal auch in RetroShare forum
« Last Edit: March 21, 2009, 11:00:30 PM by crypton »

Offline Col Parnick

  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: openssl-0.9.7g-xpgp-0.1c g++ error
« Reply #2 on: March 22, 2009, 10:21:44 AM »
Ja. Ich wusste nicht wie ich das Problem mit dem Linker umgehen sollte. Also hab ich ein ubuntu Paket genommen und das zum laufen gebracht. Ich bin auf Puppy und tinycore unterwegs. (Keine 'schöne' Lösung, weil ich einige libs überschrieben hab.)

Danke erstmal, wenn ich ein Paket für tc oder Puppy machen will meld ich mich nochmal im http://retroshare.sourceforge.net/forum/ .

OT: Unter OS X 10.4 läuft das GUI nicht.
Bis dann.