Author Topic: Mute dies after setting up Port Forwarding  (Read 8385 times)

0 Members and 1 Guest are viewing this topic.

Offline tyberius

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Mute dies after setting up Port Forwarding
« on: June 07, 2004, 09:53:13 PM »
I recently downloaded and installed Mute out of the box on Win2k.  I answered "I am behind a firewall" when I installed it.  Everything was fine and Mute appeared to work - although it was kinda slow.

I decided that I would open port 4900 on my firewall and port-forward to my machine to (hopefully) speed things up.  I changed the entry in the behindFirewall.ini setting from 1 to 0 and restarted Mute.

It seems to run for a minute or two and then dies (GPF).

Can anyone out there suggest a fix or offer some help?

Regards

Tyberius

ant

  • Guest
Mute dies after setting up Port Forwarding
« Reply #1 on: June 08, 2004, 06:00:57 AM »
Hi tyberius,

Can you tell whether your GPF only happens running with the behindFirewall.ini is set to 0 or does it also happens when the behindFirewall.ini is set to 1.

I'm also running MUTE from behind a firewall with port forwarding and the behindFirewall.ini set to 0. I let one instance of MUTE run 24/7. For downloads I use another instance of MUTE using another port which is also forwarded.
I found out that running MUTE, on my Win98-testmachine, for more than 2 days without restarting there is a memory shortage problem :o . There could be a memory leak problem in MUTE. I'm not sure because there are several other programs running on that same machine. The next couple of days I will look into the memory problem by running only one and after that multiple instances of MUTE on the machine.

Offline Markus

  • Administrator
  • Elite
  • *****
  • Posts: 5740
  • Karma: +25/-8
    • View Profile
    • http://www.planetpeer.de
Re: Mute dies after setting up Port Forwarding
« Reply #2 on: June 08, 2004, 06:44:50 AM »
Quote from: tyberius
I recently downloaded and installed Mute out of the box on Win2k.  I answered "I am behind a firewall" when I installed it.  Everything was fine and Mute appeared to work - although it was kinda slow.

Slow download rates are the price you have to pay for anonymity. Do you know the specs of MUTE? If you want to know more about it you should read "How MUTE helps you to protect your privacy" on the MUTE homepage.

Quote

It seems to run for a minute or two and then dies (GPF).

Can you see an entry in the eventlog concerning this gpf?

CU,
Markus


Cheers,
Markus

Offline tyberius

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Mute dies after setting up Port Forwarding
« Reply #3 on: June 09, 2004, 12:46:52 AM »
Quote
Can you tell whether your GPF only happens running with the behindFirewall.ini is set to 0 or does it also happens when the behindFirewall.ini is set to 1.


I switched back to '1' and again it is dying after about 5 min.  I checked mute.log and it appears that I am note getting connected to any hosts - ever...

L4 | Tue Jun 08 18:24:43 2004 (557 ms) | ConnectionMaintainer | Timed out connecting to host.
L2 | Tue Jun 08 18:24:43 2004 (557 ms) | ConnectionMaintainer | Connection failed to 172.176.2.206:4900
L4 | Tue Jun 08 18:24:43 2004 (557 ms) | ConnectionMaintainer | Adding a connection failed.
L4 | Tue Jun 08 18:24:43 2004 (557 ms) | ConnectionMaintainer | Trying to add a new connection.
L4 | Tue Jun 08 18:24:43 2004 (557 ms) | ConnectionMaintainer | Trying to connect to 64.53.160.49:4900
L4 | Tue Jun 08 18:24:49 2004 (345 ms) | ChannelReceivingThread 64.53.160.49:4900
 | Starting up.
L4 | Tue Jun 08 18:24:49 2004 (345 ms) | ConnectionMaintainer | Trying to add a new connection.
L4 | Tue Jun 08 18:24:49 2004 (345 ms) | ConnectionMaintainer | Trying to connect to 66.169.232.17:4900
L4 | Tue Jun 08 18:24:54 2004 (353 ms) | ConnectionMaintainer | Timed out connecting to host.
L2 | Tue Jun 08 18:24:54 2004 (353 ms) | ConnectionMaintainer | Connection failed to 66.169.232.17:4900
L4 | Tue Jun 08 18:24:54 2004 (353 ms) | ConnectionMaintainer | Adding a connection failed.
L4 | Tue Jun 08 18:24:54 2004 (353 ms) | ConnectionMaintainer | Trying to add a new connection.
L4 | Tue Jun 08 18:24:54 2004 (353 ms) | ConnectionMaintainer | Trying to connect to 206.201.3.100:4900
L4 | Tue Jun 08 18:24:59 2004 (360 ms) | ConnectionMaintainer | Timed out connecting to host.

Quote
Slow download rates are the price you have to pay for anonymity.


Agreed.  I have read all the dox I can get my hands on  :wink:

Quote
Can you see an entry in the eventlog concerning this gpf?


No.  There are entries in the eventlog.  The strange things is that when I first tried Mute, it seemed to work.  I never did get a complete file downloaded and it appears that other inbound connections were not fully serviced.  I never did see %100 complete when people were accessing my node.

Thanks for your help!  If you have anymore suggestions then I'm open ears!  Does anyone know of a way of getting more verbose logging?

I may try reinstalling to see if that has an effect.

Kind regards,

Tyberius

Offline tyberius

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Mute dies after setting up Port Forwarding
« Reply #4 on: June 09, 2004, 01:02:20 AM »
Oh ya....  I have also seen this error message in mute.log...

   readStreamUpToTag | Failed to find end tag "Body:", read 0 characters:

...shortly before the GPF

ant

  • Guest
Mute dies after setting up Port Forwarding
« Reply #5 on: June 09, 2004, 05:21:13 AM »
Quote from: tyberius
Quote

Thanks for your help!  If you have anymore suggestions then I'm open ears!  Does anyone know of a way of getting more verbose logging?


From the readme file:

-- logLevel.ini
-- Range:  string values of DEACTIVATE_LEVEL, CITICAL_ERROR_LEVEL, ERROR_LEVEL, WARNING_LEVEL, INFO_LEVEL, DETAIL_LEVEL or TRACE_LEVEL.
The amount of detail to include in the general log, which is stored in the file "MUTE.log".  DEACTIVATE_LEVEL disables logging, CRITICAL_ERROR_LEVEL shows the least detail, and TRACE_LEVEL shows the most detail.


In the bug list on sourceforge.net (http://sourceforge.net/tracker/?group_id=83030&atid=568085) somebody reported the following on 2004-05-03 17:51

"Will not run under Windows 2000
When I try to run Mute, it just disappears after I enter a random seed.
I have no idea what's causing it."

I don't know if this is a version 0.2.2 or a version 0.3 bug report.

So, give it a try with TRACE_LEVEL set, but keep an eye on the MUTE.log file because it will become very large.

Hope that you find something more accurate what causes the problem so it can be added to that bug report.

Offline Encrypt

  • Regular
  • **
  • Posts: 34
  • Karma: +0/-0
    • View Profile
Mute dies after setting up Port Forwarding
« Reply #6 on: June 09, 2004, 08:45:07 PM »
It's a longshot but here's an idea:

Set your minimum connections to 10 and your max connections to 20.  Let Mute churn a good 20 minutes to half an hour before trying to download anything.

Offline tyberius

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Mute dies after setting up Port Forwarding
« Reply #7 on: June 10, 2004, 02:20:51 PM »
Quote
From the readme file:

-- logLevel.ini


Thanks for the verbose log settings!  (I know, I know, "RTFM"...)

I set TRACE_LEVEL and fired up Mute again.  I didn't see anything that stuck out other than an IP address in the host list that is non-numeric ("asdasdasd 4900").

L4 | Thu Jun 10 06:20:14 2004 (740 ms) | ConnectionMaintainer | Trying to connect to 82.48.24.12:4900
L4 | Thu Jun 10 06:20:20 2004 (558 ms) | readStreamUpToTag | Failed to find end tag "EndPublicKey", read 0 characters:


L2 | Thu Jun 10 06:20:20 2004 (558 ms) | SecureStreamFactory | Failed to receive their public key
L4 | Thu Jun 10 06:20:20 2004 (558 ms) | ConnectionMaintainer | Adding a connection failed.

<snip>

L4 | Thu Jun 10 06:21:03 2004 (831 ms) | ConnectionMaintainer | Trying to add a new connection.
L4 | Thu Jun 10 06:21:03 2004 (831 ms) | ConnectionMaintainer | Trying to connect to 217.255.11.44:4900
L6 | Thu Jun 10 06:21:05 2004 (784 ms) | ChannelReceivingThread 172.147.10.85:4900
 |
HostCount: 49
217.234.231.117 4900

<snip>

212.21.84.250 4900
asdasdasd 4900
217.93.187.219 4900

<snip>

62.3.77.178 4900
EndHostList
L4 | Thu Jun 10 06:21:08 2004 (848 ms) | ConnectionMaintainer | Timed out connecting to host.
L2 | Thu Jun 10 06:21:08 2004 (848 ms) | ConnectionMaintainer | Connection failed to 217.255.11.44:4900


Quote from: Encrypt
It's a longshot but here's an idea:

Set your minimum connections to 10 and your max connections to 20.  Let Mute churn a good 20 minutes to half an hour before trying to download anything.


I tried setting inBoundConnections to 10 and MaxConnections to 20 but it still died.  I have yet to re-install but that willbe next on my list.

Is anyone aware of problems using McAffee personal firewall with Mute?  I do have a rule set to allow TCP/UDP in/out on port 4900 so I don't believe that this might be the issue.

Regards,

Tyberius

Offline nglwarcry

  • Advanced
  • ***
  • Posts: 190
  • Karma: +2/-0
    • View Profile
Mute dies after setting up Port Forwarding
« Reply #8 on: June 10, 2004, 08:01:15 PM »
Quote from: tyberius

Is anyone aware of problems using McAffee personal firewall with Mute?  I do have a rule set to allow TCP/UDP in/out on port 4900 so I don't believe that this might be the issue.

Regards,

Tyberius

you can use sygate personal firewall, free for personal use, and see if with it you can solve this problem or if it's not a firewall issue.
nglwarcry

Anonymous

  • Guest
Mute dies after setting up Port Forwarding
« Reply #9 on: June 11, 2004, 05:28:03 PM »
Quote from: tyberius
Quote

Is anyone aware of problems using McAffee personal firewall with Mute?  I do have a rule set to allow TCP/UDP in/out on port 4900 so I don't believe that this might be the issue.


I'm using MPF here and MUTE works just fine, so I probably isn't that.

Offline Markus

  • Administrator
  • Elite
  • *****
  • Posts: 5740
  • Karma: +25/-8
    • View Profile
    • http://www.planetpeer.de
Mute dies after setting up Port Forwarding
« Reply #10 on: June 11, 2004, 06:39:46 PM »
Quote from: Anonymous
Quote from: tyberius
Quote

Is anyone aware of problems using McAffee personal firewall with Mute?  I do have a rule set to allow TCP/UDP in/out on port 4900 so I don't believe that this might be the issue.


I'm using MPF here and MUTE works just fine, so I probably isn't that.


@Guest:

Maybe you have another version of the McAfee personal firewall than tyberius?


Cheers,
Markus

Offline Markus

  • Administrator
  • Elite
  • *****
  • Posts: 5740
  • Karma: +25/-8
    • View Profile
    • http://www.planetpeer.de
Mute dies after setting up Port Forwarding
« Reply #11 on: June 11, 2004, 06:43:41 PM »
@tyberius:

Did you try the text mode version of MUTE as well to see if you can reproduce the crash? Itīs just an idea to see if it does happen also...


Cheers,
Markus

Belly Dancer

  • Guest
Mute Its a scam
« Reply #12 on: June 13, 2004, 02:32:36 AM »
well i downloade the Mute run some tests to see it it worked ,it did brought back results, great now doing that i was able to obtain the IP adress of the resorse , well i as a matter of fact it also kept a log on the IP adresess for the you (RIAA,MPA ,BSA etc ) to make it easier to to go after who ever shares on the web, allthou it sounds convincieg to an avreage Joe Shmoe that this is realy "annonymous" well its not dont be fould of who ever tells you that it is,i returned 5 IP adress belonging to ISP , i think i said enough i personaly dont download or upload files on internet i just did this as an education, thank you and have a Great Day  :D

Offline Markus

  • Administrator
  • Elite
  • *****
  • Posts: 5740
  • Karma: +25/-8
    • View Profile
    • http://www.planetpeer.de
Re: Mute Its a scam
« Reply #13 on: June 13, 2004, 11:35:23 AM »
Quote from: Belly Dancer
well i downloade the Mute run some tests to see it it worked ,it did brought back results, great now doing that i was able to obtain the IP adress of the resorse ,

First off, I guess that you donīt know much about the concept behind MUTE? :wink: Could you explain what you mean with resource?

Quote

well i as a matter of fact it also kept a log on the IP adresess for the you (RIAA,MPA ,BSA etc ) to make it easier to to go after who ever shares on the web, allthou it sounds convincieg to an avreage Joe Shmoe that this is realy "annonymous" well its not dont be fould of who ever tells you that it is,i returned 5 IP adress belonging to ISP , i think i said enough i personaly dont download or upload files on internet i just did this as an education, thank you and have a Great Day  :D


Well, please do not forget: Nobody is really anonymous and it would be a great mistake to believe this ;-) But why do you came to the conclusion that MUTE is a scam? How did you reveal this IP addresses? With a "netstat -an" on the Windows command line?

If I were you I would better read the description of MUTE at the homepage (http://mute-net.sourceforge.net/howPrivacy.shtml).


Cheers,
Markus

Offline tyberius

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Mute dies after setting up Port Forwarding
« Reply #14 on: June 23, 2004, 05:05:30 AM »
Sorry that I have been away for awhille and not working towards resolving this problem.  I was running Mute again tonight.  I haven't reinstalled yet or tried running the text-only version yet (someday soon! :roll: )

As I was watching Mute try to connect, McAffee Firewall popped up and said that I was trying to connect to a non-existent IP (0.0.19.36). Mute then crashed!  Could I somehow be getting passed a bogus IP from somewhere else?  Or is this merely a coincidence?!?!?

Regards,

Tyberius