Author Topic: Stable Build 5093 (has a bug!)  (Read 2024 times)

0 Members and 1 Guest are viewing this topic.

Offline Nemo

  • Global Moderator
  • Elite
  • *****
  • Posts: 1303
  • Karma: +27/-0
    • View Profile
Stable Build 5093 (has a bug!)
« on: September 03, 2004, 08:00:16 AM »
Source: http://article.gmane.org/gmane.network.freenet.devel/15347

[code:1]
From: Toad <toad@...>
 Subject: Stable build 5093
 Newsgroups: gmane.network.freenet.devel, gmane.network.freenet.support
 Date: Wed, 01 Sep 2004 21:44:56 +0100
 
Freenet stable build 5093 is now available. The snapshots have been
updated. Please upgrade, test, report bugs.

To upgrade:
On Windows, use the update option on the start menu, if it is there.
On linux, stop the node, run update.sh, and start it.
On any platform, stop the node, fetch
http://freenetproject.org/snapshots/freenet-latest.jar and overwrite
your existing freenet.jar with it, then restart the node.

Major changes:
4 major bugfixes to queueing.
- We would sometimes send a request back to the node the request had
  been received from.
- We would sometimes send a request to a node we had already routed it
  to.
- Timeouts were wrong for local requests.
- The send request counter was not being updated. This could cause
  permanently high load, which would cause high MRIs and nodes to
  effectively freeze up, eventually accepting virtually no queries.
--
Matthew J Toseland - toad@...
Freenet Project Official Codemonkey - http://freenetproject.org/
ICTHUS - Nothing is impossible. Our Boss says so.

_______________________________________________
Devl mailing list
Devl@...
http://dodo.freenetproject.org/cgi-bin/mailman/listinfo/devl (Bugfixes
[/code:1]

Greetings,
Nemo.