Author Topic: Can't seem to get RShare running?  (Read 4509 times)

0 Members and 1 Guest are viewing this topic.

Offline no idea

  • Posts: 3
  • Karma: +0/-0
    • View Profile
Can't seem to get RShare running?
« on: October 14, 2006, 08:47:32 AM »
I've downloaded Microsoft .Net Framework Version 2, and then downloaded both the

http://rshare.de/downloads/RShare_0.7_BINARY_PRERELEASE4.zip

and the

http://rshare.de/downloads/RShare_2006-10-08.zip

I then opened the files through explorer and they were extracted as the following files respectively:-

RShare_0.7_BINARY_PRERELEASE4

and

RShare_2006-10-08

But i can't seem to do anything with those files!!  The icons arn't recognised - what am i supposed to do now? ???

Offline philharmoni

  • Elite
  • *****
  • Posts: 878
  • Karma: +10/-0
    • View Profile
Re: Can't seem to get RShare running?
« Reply #1 on: October 14, 2006, 09:35:40 AM »
Hello and welcome!

First: Do you have Microsoft Windows? At the moment, RShare only runs on Windows OSes!
Then: To run RShare you have to INSTALL the .NET Framework 2.0 FIRST and then REBOOT your System.

You only need the RShare 0.7 Prerelease 4 package or a COMPILED version of the actual beta release (RShare_2006-10-08.zip are only the C# sources!) available here: http://rapidshare.de/files/35963306/RShare_2006-10-08.zip.html

You only have to run RShare by clicking on the RShare icon (it needs up to 30 seconds to start the programm and to connect wirh the network). In the Prelease 4 package you also have to update the webcaches in preferences window. Under http://board.planetpeer.de/index.php/topic,1964.0.html you can find an actual list of webcaches. Then restart RShare. In the actual beta-version 2006-10-08 webcaches update automatically.

I hope, RShare will work now and sorry for my broken english - i'm german!
« Last Edit: October 14, 2006, 12:09:13 PM by philharmoni »

Offline no idea

  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Can't seem to get RShare running?
« Reply #2 on: October 14, 2006, 12:29:33 PM »
Hello and welcome!

First: Do you have Microsoft Windows? At the moment, RShare only runs on Windows OSes!
Then: To run RShare you have to INSTALL the .NET Framework 2.0 FIRST and then REBOOT your System.

You only need the RShare 0.7 Prerelease 4 package or a COMPILED version of the actual beta release (RShare_2006-10-08.zip are only the C# sources!) available here: http://rapidshare.de/files/35963306/RShare_2006-10-08.zip.html

You only have to run RShare by clicking on the RShare icon (it needs up to 30 seconds to start the programm and to connect wirh the network). In the Prelease 4 package you also have to update the webcaches in preferences window. Under http://board.planetpeer.de/index.php/topic,1964.0.html you can find an actual list of webcaches. Then restart RShare. In the actual beta-version 2006-10-08 webcaches update automatically.

I hope, RShare will work now and sorry for my broken english - i'm german!

Many Thanks for your help on this one philharmoni :)

I've managed to get it working this time by following your link to the above and downloading the RShare_2006-10-08 file, however i don't seem to understand the bit about changing the list of webcaches.

I followed your link to the webcaches, and it takes me to another part of the forum which has various hyperlinks, but what do i have to do?

Sorry to be a pain, but don't have much experience with filesharing programs.

Also - how can i confirm exactly what files the program is shaing from my PC?

Thank you for your assistance :)

Offline Markus

  • Administrator
  • Elite
  • *****
  • Posts: 5740
  • Karma: +25/-8
    • View Profile
    • http://www.planetpeer.de
Re: Can't seem to get RShare running?
« Reply #3 on: October 14, 2006, 12:39:59 PM »
I've managed to get it working this time by following your link to the above and downloading the RShare_2006-10-08 file, however i don't seem to understand the bit about changing the list of webcaches.

I followed your link to the webcaches, and it takes me to another part of the forum which has various hyperlinks, but what do i have to do?

Sorry to be a pain, but don't have much experience with filesharing programs.

Also - how can i confirm exactly what files the program is shaing from my PC?

Thank you for your assistance :)
@no idea:

I would highly recommend to check out our RShare related help topics in the Planet Peer Wiki: http://www.planetpeer.de/wiki/index.php/RShare_%28English%29

If you use the current unstable edition of RShare your Web Caches list should be recent enough so there´s no need actually to modify them manually. Just in case your Web Caches file is completely outdated you might want to use the RShare Web Cache Updater I´ve written in order to update your webcaches.xml file automatically.

Lars, the author of RShare, has by the way planned automatic Web Cache updates for the release version of RShare so manually updates are not longer necessary then.

If you have further questions do not hesitate to ask :)






Cheers,
Markus

Offline no idea

  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Can't seem to get RShare running?
« Reply #4 on: October 14, 2006, 01:27:21 PM »
Thanks for your reply Markus :)

I've looked at the link, however i don't have a 'Webcaches' tab listed on the Preferences Tab?

Also, i'm in the process of downloading 2 <deleted> songs  :-[ and they are taking forever to get started downloading.  Its been about 1/2 hour and they still haven't started doing anything yet.  The Bytes Completed displays 0Bytes.?

I have a full list of Peers listed, some with red lights, green, and yellow lights.  Also, i have a list of Connections listed as IP Addresses.  Does this mean i'm properly connected and my firewall is allowing proper connection?  If i'm properly connected then why isn't it doing anyting?

Also - i would have thought there would have been tonnes of songs from <deleted> listed - however only 5 files were found? ???

// Edited by Markus: Removed artist name -> read the board policy!
« Last Edit: October 14, 2006, 02:07:52 PM by Markus »

Offline philharmoni

  • Elite
  • *****
  • Posts: 878
  • Karma: +10/-0
    • View Profile
Re: Can't seem to get RShare running?
« Reply #5 on: October 14, 2006, 02:22:19 PM »
I've looked at the link, however i don't have a 'Webcaches' tab listed on the Preferences Tab?

In this version of rshare, the webcaches tab isnt needed anymore because the webcaches-list updates automatically.

Also, i'm in the process of downloading 2 Kylie songs  :-[ and they are taking forever to get started downloading.  Its been about 1/2 hour and they still haven't started doing anything yet.  The Bytes Completed displays 0Bytes.?

For each file exists a download-queue (other users who wants to download the same file). So your download starts, if you are on place 0 of the queue. When it did'nt, a reason could be, that the sources of the files are'nt available anymore. But at the moment there also are some bugs left in rshare which prevent optimal download-behavior in some cases. This probably would be better in the next releases.

I have a full list of Peers listed, some with red lights, green, and yellow lights.  Also, i have a list of Connections listed as IP Addresses.  Does this mean i'm properly connected and my firewall is allowing proper connection?

Yes.

Also - i would have thought there would have been tonnes of songs from Kylie listed - however only 5 files were found? ???

In RShare there are some 1500 music files available at the moment and this is far away from tons of them. But the RShare network grows rapidly.

Some last words: Always remember, that RShare is anonymous, but boards like this are'nt. So dont post any comments or requests for copyrighted materials here!
« Last Edit: October 14, 2006, 02:24:01 PM by philharmoni »

Offline Markus

  • Administrator
  • Elite
  • *****
  • Posts: 5740
  • Karma: +25/-8
    • View Profile
    • http://www.planetpeer.de
Re: Can't seem to get RShare running?
« Reply #6 on: October 14, 2006, 02:24:22 PM »
Thanks for your reply Markus :)

I've looked at the link, however i don't have a 'Webcaches' tab listed on the Preferences Tab?
Your are right, the Web Caches tab is missing in the current unstable version.

Quote
Also, i'm in the process of downloading 2 <deleted> songs  :-[ and they are taking forever to get started downloading.  Its been about 1/2 hour and they still haven't started doing anything yet.  The Bytes Completed displays 0Bytes.?
Well, we are talking about anonymous filesharing, right? You should not compare RShare with larger networks like eDonkey or so. Sometimes it leasts hours(!) until a downloads starts because the node who is sharing the file is/was offline, so you have to wait until he´s back online.

Do not forget that the number of participating nodes and the available node can´t be compared with traditional p2p networks yet, but we see the RShare networking growing daily :)

Quote
I have a full list of Peers listed, some with red lights, green, and yellow lights.  Also, i have a list of Connections listed as IP Addresses.  Does this mean i'm properly connected and my firewall is allowing proper connection?  If i'm properly connected then why isn't it doing anyting?
In short: The greener, the better. If you see peers with a green icon and type 0(0) you know that you´ve good connections.

Quote
Also - i would have thought there would have been tonnes of songs from <deleted> listed - however only 5 files were found? ???
See my comment above regarding this.


Cheers,
Markus